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Understanding Release Streams

This section includes:

• “Overview of Release Streams” on page 2

• “Determining Your Current Release Stream” on page 5

• “Switching Release Streams” on page 6

Overview of Release Streams

Beginning with IRIX 6.5, a new software release process delivers IRIX
upgrades to you in a more easily manageable and consistent fashion.

In this new process, a family of releases is anchored with the initial major
operating system release. During your first upgrade to an intermediate
release, known as an overlay, you will be asked to choose a release stream,
which becomes the stream automatically chosen for you in subsequent IRIX
6.5.x upgrades.

Because 6.5.x releases are cumulative, you do not need to upgrade to the
previous 6.5.x release in order to upgrade to a new one.

For example, if you are running 6.5.1, and want to upgrade to 6.5.3, you do not
need to upgrade to 6.5.2 before you upgrade to 6.5.3. Instead, you may
upgrade directly from 6.5.1 to 6.5.3.
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Similarly, if you are running a pre-6.5 version of IRIX you can install the 6.5
and 6.5.x software at the same time. For example, if you are running 6.2, and
want to upgrade to 6.5.3, you do not need to upgrade to 6.5, then 6.5.1, then
6.5.2, before you upgrade to 6.5.3. Instead, you may upgrade directly from 6.2
to 6.5.3.

The sections that follow describe these concepts in more detail.

Understanding Release Streams

Overlay releases are divided into two sets of products, called release streams,
as described below.  Both streams are on the same CDs.

Choose the maintenance stream if you want to upgrade your system with
only the fixes that are essential to maintaining stability and compatibility.
Choose the feature stream if you want the maintenance stream content plus
new software features.

A maintenance stream contains: A feature stream contains:

■ Accumulated bug fixes

■ Basic support for new
hardware and hardware
upgrades

■ Accumulated bug fixes

■ Basic support for new
hardware and hardware
upgrades

■ New software features
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Once you choose a release stream, it becomes your default upgrade path. For
example, if you chose the feature stream for 6.5.2, then when you upgrade to
6.5.3, Software Manager (or Inst) will assume you wish to install from the
feature stream content. “Switching Release Streams” on page 6 tells you how
to change streams if you change your mind after an upgrade.

Understanding the “Release Family”

Major IRIX releases are those in which Silicon Graphics performs major
infrastructure work. They are generally backward compatible and are the
releases in which support for older platforms and software is discontinued.
Major releases occur on cycles of approximately 24 months, and they are
released on all platforms that are supported at the time of the release.

Intermediate releases, called overlays, are used to fix problems or add
enhancements and new hardware support. These releases are guaranteed to
maintain backward and forward binary compatibility, which means that
applications built on any member of a release family will run correctly on
other members of that release family. Overlay releases are cumulative, unless
otherwise specified. Therefore, each overlay release includes the fixes and
features from the previous overlay release. This allows you to upgrade to the
most current release in one step.

Advantages: System Administration and Compatibility

IRIX 6.5 overlay releases support all platforms supported by the major 6.5
release, as well as later platforms, and therefore system administrators can
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maintain just one network distribution or set of CDs to support all Silicon
Graphics systems and peripherals. Also, because these overlay releases are
cumulative, system administrators do not have to create archives of IRIX
release upgrade media.

For developers, application development will be easier because releases
provide support for all platforms, and release families are backward and
forward compatible within the major operating system line (assuming
programs are not written to explicitly require new features introduced in any
of the intermediate releases).

Determining Your Current Release Stream

If your system is running a 6.5.x version of IRIX, it will either be on the
maintenance or feature release stream.

Note:  If the system is running IRIX 6.5 or earlier, a release stream has not yet
been designated. You will be asked to choose the release stream the first time
you install an overlay.
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You can determine a system’s current release stream in one of two ways:

Switching Release Streams

This section tells you how to change the release stream that has been
previously designated on your system. If your system is running a 6.5 or
earlier version of IRIX, this section is not yet relevant for you—release streams
began with 6.5.1. If you don’t want to change release streams, proceed to the
installation instructions (refer to the table of contents on page 1).

You can switch streams in either of the following situations:

In Software Manager: In a shell:

■ Open Software Manager
by choosing System >
Software Manager from
the Toolchest.

■ Below the Lookup button
you see either Stream:
Maint or Stream: Feat.
“Maint” indicates
maintenance stream and
“Feat” means feature
stream.

■ Enter uname -R

■ The output line includes
an IRIX version number
that ends with f  or m,
where m indicates
maintenance and f
indicates feature.
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• When upgrading from one 6.5.x version of IRIX to another 6.5.x version

• When you have already installed a 6.5.x release using one stream, but
would like to switch to the other stream

Switching streams is similar to the IRIX 6.5.x upgrade on 6.5. or later, with a
few important exceptions.

To switch release streams:

To switch streams, read the following applicable exceptions first, then
incorporate them into the steps listed in “Installing an IRIX 6.5.x Release on
IRIX 6.5 or Later” on page 11. (If your system does not have a graphical
interface, see “Installing 6.5.x on a System Without a Graphical Interface” on
page 43.)

• When you open Software Manager, choose File > Set Preferences... In the
dialog that appears, scroll to stream , select it, then click to choose
“Maint” or “Feature” from choices that appear on the right. Click Apply.

Note: If you are using Inst to switch streams, use the Inst commands set
stream feature or set stream maint when the Inst prompt first appears.

• For Feature to Maintenance switches only:

– open your core IRIX 6.5 CDs during the step in which you open
the overlay CDs. (Do this during the Overlay Installation, not the
Patch Installation.)
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– use these installation commands (for product selection) instead of
the ones given in the regular instructions:

set neweroverride on

install downgrades

install upgrades

install prereqs

keep incompleteoverlays

You may see no matches  messages. This does not indicate an error.

• For Maintenance to Feature switches only:

You may not have to open any 6.5 CDs. If you do need to, you will be
prompted with conflict messages that look similar to the following (the
product names and numbers will differ):

Overlay product eoe.sw.base (1275066720) cannot be
installed because of missing prerequisites: base
product eoe.sw.base (1274627340)

1a. Do not install eoe.sw.base (1275066720)

1b. Also install base product eoe.sw.base
(1274627340) from an additional distribution --
insert another CD or specify another software
distribution
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If you see a conflict message like this, choose to open the distribution or
CD that contains the missing product, then select the product for
installation. In Software Manager, follow these steps:

1. Choose “Open new distribution to resolve conflict.”

2. Insert the CD that contains the missing product. (If you don’t know
which CD to use, see Note below.)

3. Type /CDROM/dist  (or the remote distribution location if applicable)
in Distribution field of the “Open Additional Distribution” dialog.

4. Click Add.

5. Click to select the missing product.

6. Continue with the installation.

Note: If you aren’t sure which 6.5 CD the missing product is on, you have
two choices:

• Find out which CD it is on by looking the product up in the CD
Descriptions sections of the Start Here pages. (See “How to Access the
Start Here Pages” on page 60.)
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• Or, insert each of the 6.5 CDs and enter the selection commands after
opening each CD:

keep *

install standard

install prereqs

keep incompleteoverlays

Once a new release stream has been chosen, Software Manager will
display only the products that are in the chosen stream.
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Installing an IRIX 6.5. x Release on IRIX 6.5 or Later

In order to follow these instructions, your system must already be running
IRIX 6.5 or later. If it is not, follow “Installing an IRIX 6.5.x Release on a Pre-6.5
Version of IRIX” on page 24. To install on a system that does not have a
graphical interface, see “Installing Software on a System Without a Graphical
Interface” on page 42.

Because 6.5.x releases are cumulative, you do not need to upgrade to the
previous 6.5.x release in order to upgrade to a new one.

For example, if you are running 6.5.1, and want to upgrade to 6.5.3, you do not
need to upgrade to 6.5.2 before you upgrade to 6.5.3. Instead, you may
upgrade directly from 6.5.1 to 6.5.3.

If you need to determine your system’s IRIX version, enter the following in a
shell window: uname -R

This section includes:

• “Quick Summary for Experienced Users” on page 12

• “Detailed Instructions: Installing 6.5.x on IRIX 6.5 or Later” on page 14
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Quick Summary for Experienced Users

All users should follow the “Detailed Instructions: Installing 6.5.x on IRIX
6.5 or Later” on page 14. However, this section provides a quick summary
for experienced Inst users.

1. Preparation Summary

Print or check the Start Here pages for information you need before
you begin, such as:

• Minimum system requirements for this release

• Any major installation caveats

See “How to Access the Start Here Pages” on page 60. (The Start Here
pages include additional useful information, such as descriptions of
each CD.)

If you want to switch to a different release stream, see “Switching
Release Streams” on page 6.

2. Patch Installation Summary

In order to do a live (not miniroot) upgrade, you need the “Installation
tools to support overlays” patch. If not, install it from the
/CDROM/installtools directory on the Installation Tools and Overlays
CD. Exit Inst or Software Manager after you install it.
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3. Overlay Installation Summary

Use Inst or Software Manager to install products from the CDs you
received in your overlay package.

Important notes:

• Open IRIX 6.5.x Installation Tools and Overlays first.

• Each CD must be inserted and read by Software Manager before
you begin the installation selections.

• To install upgrades and related (prerequisite) products:

Inst>  keep *

Inst>  install standard

Inst> install prereqs

Inst> keep incompleteoverlays

• If you haven’t already chosen a stream in a previous installation,
you will be prompted to select the maintenance or feature stream.
See “Overview of Release Streams” on page 2 for details.

4. Postinstallation Summary

Although every product has an associated release note that informs
you of any major bugs and workarounds, Silicon Graphics has
collected information on bugs that could most significantly affect your
experience once you upgrade, and posted them as “Caveats to Read
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After Upgrading.” This documentation is installed on your system, by
default. You can see them after you restart and log in. To do so, bring
up a Web browser and enter this address:
file:/var/www/htdocs/WhatsNew/precaveats.html

In addition to reviewing this list, you may want to check ”Caveat and
Release Note Updates” at http://support.sgi.com/6.5/ for any
late-breaking information.

Detailed Instructions:
Installing 6.5.x on IRIX 6.5 or Later

Before you Begin

1. Print or check the Start Here pages for information you need before you
begin, such as:

• Minimum system requirements for this release

• Any major installation caveats

See “How to Access the Start Here Pages” on page 60.

Note: The Start Here pages include additional useful information, such as
descriptions of each CD.
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Patch Installation

To be able to perform a live (as opposed to miniroot) installation of the 6.5.x
installation, first install the “Installation tools to support overlays” patch as
described in the following steps.
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2. Follow the instructions below to bring up Software Manager and the
distribution that contains the patch:

If installing from a CD connected
to your system:

If installing from a distribution or
CD on a remote system:

■ Insert the “Installation
Tools and Overlays” CD
in the CD drive.

■ Open Software Manager
by double-clicking the
CDROM icon on your
desktop.

■ If a README window
appears, read it and click
Dismiss.

■ Edit the Available
Software field so that it
displays the installtools
directory. Enter:

/CDROM/installtools

■ From your Toolchest,
choose System > Software
Manager.

■ In the Available Software
field, enter the remote
system’s name and the
location of the installtools
directory of the
“Installation Tools and
Overlays” distribution.

For example, if it is in a
CD drive on a remote
system named mars, enter:

mars:/CDROM/installtools

■ If a README dialog
appears, read it and click
Dismiss.
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Note: If a network error message appears, refer to “Troubleshooting
Remote Installations” on page 54.

A Readme window appears. Read it and click Dismiss.

3. Click the Customize Installation... button.

4. Open the Software menu and make sure that “Short Product Names” is
not selected. (A check mark indicates that it is selected.)

5. Confirm that your system needs this patch:

■ If, in the Software Inventory list, next to “Installation tools to support
overlays,” you see New or Upgrade, proceed to step 6 to install the
patch.

■ If you see the phrase Older Version or Same Version next to “Installation
tools to support overlays,” this patch is already installed. Quit
Software Manager and cancel the installation, then proceed to step 9 to
begin the overlay installation.

6. Make sure that the “Installation tools to support overlays” patch is
selected.

7. Click the Start button.

8. When the installation is complete, choose File > Quit. (Do not install any
other products yet.)
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Overlay Installation

The “Installation tools to support overlays” patch must be installed (as
described above) before you begin step 9.

9. Follow the instructions below to bring up Software Manager and the
software distribution:

If installing from a CD connected
to your system:

If installing from a distribution or
CD on a remote system:

■ The “Installation Tools
and Overlays” CD should
still be in the CD drive. If
it isn’t, insert it in the
drive now.

■ Open Software Manager
by double-clicking the
CDROM icon on your
desktop.

The Available Software
field should display
/CDROM/dist .

■ From your Toolchest,
choose System > Software
Manager.

■ Enter the remote system’s
name and the location of
the “Installation Tools and
Overlays” distribution in
the Available Software
field.

For example, if it is in a
CD drive on a remote
system named mars, enter:

mars:/CDROM/dist
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Note: If a network error message appears, refer to “Troubleshooting
Remote Installations” on page 54.

10. Click the Customize Installation... button.

11. As Software Manager begins to read the CD, a dialog will ask you to
select a software stream if you have not already done so in a previous
installation. If you aren’t sure what to choose, see “Overview of Release
Streams” on page 2 for more information about release streams.

If you have selected a release stream during a previous installation, but
want to switch to a different stream during this installation, read the
special instructions given in “Switching Release Streams” on page 6.

Note: Unlike patches or patchsets, the files that are replaced in a release
stream are not saved during installation. Therefore, if you wish to change
release streams after your initial choice, you may need to use CDs from the
major release (IRIX 6.5) during the installation. Details are in “Switching
Release Streams” on page 6.

12.  A dialog prompts you to insert any other CDs that were included in the
IRIX overlay package (for example, any WorldView language support
CDs).
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The CDs must be opened now because Software Manager needs to read
the product descriptions before you begin the installation selections.

To open the CDs:

■ Eject the current CD and insert the next one. (See the table below for
location-specific instructions.)

■ Click the Add button.

■ When all CDs have been added, click Done.

13. To enter the install commands, the Command pane must be open. If it
does not appear at the bottom of the Software Manager window, choose
Panes > Command.

Software
location:

To replace the
CD or distribution:

 CD Eject the current CD by selecting the CDROM icon
(on the desktop of the system connected to the CD
drive), holding down the right mouse button, and
choosing Eject CDROM. (Alternatively, enter
eject /CDROM  in a shell.)

Distribution
Directory

Open the next directory, for example:
open mars:/irix/cd2
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Note: If you are switching from the Feature to the Maintenance stream,
use the special commands given in “Switching Release Streams” on
page 6.

To install upgrades and related (prerequisite) products, enter each of the
following lines in the Command field at the bottom of the window. (Press
Enter  after you type each line.)

keep *

install standard

install prereqs

keep incompleteoverlays

You may see a no matches  message regarding prereqs , standard , or
incompleteoverlays . This does not indicate an error.

Note: These commands are recommended because they significantly
reduce installation conflicts. Alternatively, you can click to select or
deselect products. A red check mark indicates that the product is selected
for installation.

14. If there are installation conflicts, the Conflicts button text turns red. To
display and resolve conflicts, click the Conflicts button.

• If you need to resolve conflicts by opening a CD, the installation
selections you already made may be altered on the CD you open.
Review what is selected on the CD and deselect or reselect as needed.
Or re-enter the commands given in step 13. Exception: If you are
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switching from the Feature to the Maintenance stream you must use the
special commands given in “Switching Release Streams” on page 6.

• If a conflict gives you the option of deselecting a product with “eoe” or
“Execution Environment” in the product name, do not choose to
deselect the product. The operating system needs “eoe” products in
order to function properly. Exception: You do not have to install “eoe”
products that are man (manual) pages or relnotes (release notes).

• If you deselected subsystems, conflicts may be generated by
remaining patches that go with the deselected subsystems. However,
because such patches go with subsystems you are not installing, you
do not need to install them.

15. Click the Start button.

You are prompted to open one or more specific CDs for the actual
installation. If necessary, refer to the table in step 12 for details on opening
additional CDs.

16. When a dialog appears that says “Installations and removals were
successful,” select Restart the system now and click OK.

Restarting completes the installation process.

Postinstallation

Now that the IRIX operating system is upgraded, you can also use Software
Manager to select and install any new products that were included with your
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upgrade package. See “Installing Applications on a Workstation” on page 39
or “Installing Applications From a Remote CD Drive” on page 40.

Although every product has an associated release note that informs you of
any major bugs and workarounds, Silicon Graphics has collected information
on bugs that could most significantly affect your experience once you upgrade,
and posted them as “Caveats to Read After Upgrading.” These caveats are
installed on your system, by default. You can see them after you restart and
log in. To do so, bring up a Web browser and enter this address:
file:/var/www/htdocs/WhatsNew/precaveats.html

In addition to reviewing this list, you may want to check ”Caveat and Release
Note Updates” at http://support.sgi.com/6.5/ for any late-breaking
information.
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Installing an IRIX 6.5. x Release on a Pre-6.5 Version of IRIX

Use these instructions if you have not yet upgraded to 6.5, or if you are
installing onto a clean disk. Using these instructions, you will install both the
6.5.x upgrade and the 6.5 operating system at the same time.

For example, if you are running 6.2, and want to upgrade to 6.5.3, you do not
need to upgrade to 6.5, then 6.5.1, then 6.5.2, before you upgrade to 6.5.3.
Instead, you may upgrade directly from 6.2 to 6.5.3.

If you need to determine your workstation’s IRIX version, enter the following
in a shell window: uname -R (On systems running releases prior to 6.2, enter
uname -r )

This section includes:

• “Quick Summary for Experienced Inst Users” on page 25

• “Detailed Instructions: Installing 6.5.x on a Pre-6.5 Version of IRIX” on
page 27
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Quick Summary for Experienced Inst Users

All users should follow the steps in “Detailed Instructions: Installing 6.5.x
on a Pre-6.5 Version of IRIX” on page 27. However, this section provides a
quick summary of the process for experienced Inst users.

1. Preparation Summary

• Collect the CDs you need (listed in step 1 of “Detailed Instructions:
Installing 6.5.x on a Pre-6.5 Version of IRIX” on page 27).

• Print or check the Start Here pages for information you need before
you begin, such as minimum system requirements and any relevant
installation caveats for this release. (See “How to Access the Start
Here Pages” on page 60.)

2. Preinstallation Summary

• If you are using CDs, insert the IRIX 6.5.x Installation Tools and
Overlays CD.

• Go to the miniroot.

3. CD or Distribution Reading Summary

• Before you enter any selection commands, you must correctly open
all the CDs (described in steps 7 through 12 of “Detailed
Instructions: Installing 6.5.x on a Pre-6.5 Version of IRIX” on
page 27) so that Inst can read the product descriptions on each of the
CDs or distribution directories.
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(You will be prompted to insert specific CDs again during the
installation, but all the CDs must be read now in order to prevent
many installation conflicts.)

• Open IRIX 6.5.x Installation Tools and Overlays first.

• You will be prompted to select the maintenance or feature stream.
See “Overview of Release Streams” on page 2 for details.

4. Product Selection Summary

To install upgrades and related (prerequisite) products:

Inst>  keep *

Inst>  install standard

Inst> install prereqs

Inst> keep incompleteoverlays

5. Installation Summary

• Enter go , and resolve conflicts if necessary.

• In some cases, the message that indicates which CD to insert may
include Error/Interrupt Menu —this does not signify a
problem. Insert the requested CD, and at the Interrupt prompt enter
retry .

6. Postinstallation Summary
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Although every product has an associated release note that informs
you of any major bugs and workarounds, Silicon Graphics has
collected information on bugs that could most significantly affect your
experience once you upgrade, and posted them as “Caveats to Read
After Upgrading.” These caveats are installed on your system, by
default. You can see them after you restart and log in. To do so, bring
up a Web browser and enter this address:
file:/var/www/htdocs/WhatsNew/precaveats.html

In addition to reviewing this list, you may want to check “Caveat and
Release Note Updates” at http://support.sgi.com/6.5/ for any
late-breaking information.

Detailed Instructions:
Installing 6.5.x on a Pre-6.5 Version of IRIX

Before You Begin

1. Confirm that you have the appropriate CDs or distributions. At the
minimum, you need:

• The latest 6.5.x Installation Tools and Overlays
(use this instead of the 6.5 Installation Tools CD).
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• Any other CDs that came with the overlay package.

• These CDs from the core 6.5 release package:

– IRIX 6.5 Foundation 1

– IRIX 6.5 Foundation 2

– IRIX 6.5 Applications (use if a newer Applications CD was not
included in the 6.5.x package)

– IRIX 6.5 Development Foundation (use if you are a developer)

– IRIX 6.5 Development Libraries (use if you are a developer)

• In addition to the CDs listed above, you probably received other CDs
with your IRIX 6.5 package, depending on your configuration. For
example, there are separate CDs for NFS and SoftWindows. If you
have already installed older versions of any of these products,
upgrade them during this installation. If you do not open a CD that
contains a product you have installed, “conflict” messages during
installation will prompt you to open it.

2. Print or check the Start Here pages for information you need before you
begin, such as:

• Minimum system requirements for this release

• Any major installation caveats

See “How to Access the Start Here Pages” on page 60.



29

Note: The Start Here pages include additional useful information, such as
descriptions of each CD.

Preinstallation

3. If it isn’t already in the CD drive, insert the IRIX 6.5.x Installation Tools
and Overlays CD. (If you are using a distribution directory instead of a
CD, skip this step—you will open the Installation Tools directory in step
7.)

Note: Because you need the new installation tools, do not use the IRIX 6.5
Installation Tools CD for this installation. Use the 6.5.x Installation Tools
and Overlays CD instead.

4. Bring up the system maintenance menu:

■ From the Toolchest, choose System > System Shutdown.

■ If a Shut Down dialog appears, click OK.

■ Press the Esc  key when you see Okay to power off .
Press the Esc  key immediately again when you see Starting up
the system .

A menu screen should appear now. (If it doesn’t, you probably did not
press the Esc key soon enough; begin this step again.)

5. Click Install System Software on the menu screen.
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6. Specify the location of the new software to install:

The new installation tools are loaded and a command-line interface
appears.

If the location is a CD in a drive
connected to your system:

If the location is a CD drive or a
directory on a remote system:

■ Click Local CDROM.

■ Click Install.

■ Click Continue in the
dialog box that appears.

■ If you are installing onto a
clean disk, see the Note
below.

■ Click Remote Directory.

■ Enter the name of the
remote system that
contains the distribution.

■ Enter the pathname of the
distribution source on the
remote system. For
example, if the source is a
CD, enter /CDROM/dist .

■ Click Install.

■ If a network error
message appears, refer to
“Troubleshooting Remote
Installations” on page 54.
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Note: If you are installing on a clean disk, a message appears that
includes make new filesystem , and ends with [yes/no/sh/help] .
Enter yes  to make the new filesystem. You are asked to confirm this; enter
yes . You are asked to enter a block size. If you don’t know what to enter,
enter 4096 .

CD or Distribution Reading

Before you enter any selection commands, you must follow steps 7 through 12
in order to open the CDs or distribution directories so that Inst can read the
product descriptions.

You will be prompted to open CDs again during the actual installation, but
Inst needs to read all the product descriptions first in order to prevent several
product conflicts during installation.

If you have not yet determined which CDs you need, refer to step 1.
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7. To tell Inst to read the Installation Tools and Overlays, enter the
appropriate command at the Inst prompt, as described below (depending
on the software location):

A Readme message appears.

8. You will see:
1. Place me on the maintenance stream.
2. Place me on the feature stream.
3. Cancel

Enter 1 or 2.

If you are not sure which stream to choose, refer to “Overview of Release
Streams” on page 2 for clarification. Unlike patches or patchsets, the files
that are replaced in a release stream are not saved during installation.

Software
location:

To open the
installation tools:

Local CD Enter open /CDROM/dist

Remote CD Open the CD distribution directory on the remote
system, for example: open mars:/CDROM/dist

Distribution
Directory

Open the pathname for the Installation Tools and
Overlays CD, for example:
open mars:/irix/tools
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Therefore, if you wish to change release streams after your initial choice,
you may need to use CDs from the major release (IRIX 6.5) during the
installation. For details, see “Switching Release Streams” on page 6.

9. When you see a message similar to Install software
from:[/CDROM/dist] , replace the current CD or distribution directory
with the next one.

When installing from a CD, make sure that the prompt indicates that the
installation is from the /CDROM/dist directory. For example, if the prompt
changes to reflect the /CDROM/dist/dist6.5 directory, enter /CDROM/dist
at the prompt.

Software
location:

To replace the
CD or distribution:

Local CD Eject the current CD by pressing the manual eject
button on the CD drive.

Remote CD Eject the current CD by selecting the CDROM icon
on the remote desktop, holding down the right
mouse button, and choosing Eject. (Alternatively,
enter eject /CDROM  in a shell on the remote
system.)

Distribution
Directory

Open the next directory, for example:
open mars:/irix/cd2
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10.  Press Enter  to instruct Inst to read the new CD or distribution directory.

11. Continue to replace and open each CD or distribution directory in the
manner described in the previous two steps. (Use the CDs you collected
in step 1.)

Note: Do not enter “done” until all the CDs or distribution directories
have been read. If you enter “done” too early, you can continue to insert
the rest of the CDs, but you will have to use the open command (as
described in step 7) each time.

12. When all the relevant CDs or distribution directories have been read,
enter done .

Product Selection

13. After the product descriptions on each CD have been read (as described
in the preceding steps), you can make the product selections.

To install upgrades and related (prerequisite) products:

Inst>  keep *

Inst>  install standard

Inst> install prereqs

Inst> keep incompleteoverlays

• You may see a no matches  message regarding prereqs , standard ,
or incompleteoverlays . This does not indicate an error.
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• If you are installing onto a clean disk, these commands select and
install all standard software, plus necessary prerequisite software and
patches.

• If you are familiar with using Inst, you can also choose to install new
products now. Otherwise, proceed to the next step.

Tip: For information on viewing or altering the products that are marked
for installation, save your place on this page and refer to step 17 of
“Installing 6.5.x on a System Without a Graphical Interface” on page 43.

Installation

14. Enter go  at the prompt to begin the installation.

If there are no “Conflict” messages, proceed to the next step.

If your installation selections have generated conflicts, Inst asks if you
want to address them now.

Enter 1 for “Address these conflicts now.”

To resolve conflicts, enter conflicts choice choice. For example, enter
conflicts 1b 2a to indicate that for conflict 1 you choose choice b
and for conflict 2 you choose choice a. (You can type several conflict
choices on the same line.)

• If you need to resolve conflicts by opening a CD, the installation
selections you already made may be altered on the CD you open.
Review what is selected on the CD and deselect or reselect as needed
(or re-enter the commands given in step 13).
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• If the list of conflicts is long, enter q to stop viewing the list and
resolve the conflicts currently visible on the screen. Once you’ve
resolved the visible conflicts, enter conflicts  again to view the
remaining conflicts. The other option is to write down all of your
choices before you enter them.

• If a conflict gives you the option of deselecting a product with “eoe” or
“Execution Environment” in the product name, do not choose to
deselect the product. The operating system needs “eoe” products in
order to function properly. Exception: You do not have to install “eoe”
products that are man (manual) pages or relnotes (release notes).

• If you deselected subsystems, conflicts may be generated by
remaining patches that go with the deselected subsystems. However,
because such patches go with subsystems you are not installing, you
do not need to install them.

15. Enter go  again when all conflicts are resolved. A preinstallation check
begins.
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16. When you see a message similar to

Please insert the “ CD title” CD
Type Ctrl-C to interrupt

insert the specified CD in the CD drive.

In some cases, the message that indicates which CD to insert may include
Error/Interrupt Menu —this does not signify a problem. Insert the
requested CD, and at the Interrupt prompt enter retry .

It may take several minutes for each CD to install. Eventually a new
message will prompt you to insert the next CD or indicate that the
installation is complete.

Postinstallation

17. When Inst indicates that the installation is finished, enter quit .

Postinstallation processes begin. When they are complete, you see:

Ready to restart the system. Restart?

Enter y  to restart the system, which completes the installation process.

Now that the IRIX operating system is upgraded, you can also use
Software Manager to select and install some of the new products that
were included with your 6.5.x package. See “Installing Applications on a
Workstation” on page 39.

Although every product has an associated release note that informs you
of any major bugs and workarounds, Silicon Graphics has collected
information on bugs that could most significantly affect your experience
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once you upgrade, and posted them as “Caveats to Read After
Upgrading.” These caveats are installed on your system, by default. You
can see them after you restart and log in. To do so, bring up a Web
browser and enter the following address:
file:/var/www/htdocs/WhatsNew/precaveats.html

In addition to reviewing this list, you may want to check “Caveat and
Release Note Updates” at http://support.sgi.com/6.5/ for any
late-breaking information.
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Installing Applications on a Workstation

To install applications from a CD-ROM drive that is connected to your system,
follow the instructions in the following section, “Installing Applications From
a Local CD Drive.”

To install applications from a CD-ROM drive that is connected to another
system on your network, follow the instructions in “Installing Applications
From a Remote CD Drive” on page 40.

For more details about software installation, including how to customize your
installation and troubleshoot, refer to the Software Manager Help menu.

Note: Installing applications is more simple than installing a new version of
the IRIX operating system. If you are installing a new version of IRIX, be sure
to follow the appropriate instructions (refer to the table of contents on page 1).
After you upgrade IRIX, you can log in and use Software Manager to select
and install some of the new software products that were included with your
IRIX package. To do so, use the directions in this section.

Installing Applications From a Local CD Drive

1. Insert the CD in the CD drive.

2. Open Software Manager by double-clicking the CDROM icon on your
desktop.
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3. To install all upgrades and new products, proceed to step 4; otherwise,
click Customize Installation to select specific products:

■ After the Software Inventory is displayed, click to select the products
you want to install.

■ If a product has release notes, the product name turns blue when you
click it. Click again to display release notes, or choose Selected >
Release Notes.

4. Click the Start button.

5. When the installation is complete, choose File > Quit.

6. Eject the CD from the drive:

Select the CDROM icon, hold down the right mouse button, and choose
Eject.

Installing Applications From a Remote CD Drive

1. Insert the CD in the remote CD drive.

2. From the Toolchest on your system, choose System > Software Manager.

3. In the Available Software field, enter the remote system’s name and the
distribution directory path. For example:

mars:/CDROM/dist

Note: If a network error message appears, refer to “Troubleshooting
Remote Installations” on page 54.
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4. Click the Lookup button.

5. To install all upgrades and new products, proceed to step 6; otherwise,
click Customize Installation to select specific products:

■ After the Software Inventory is displayed, click to select the products
you want to install.

■ If the product has release notes, the product name turns blue when
you click on it. Click again to display release notes, or choose Selected
> Release Notes.

6. Click the Start button.

7. When the installation is complete, choose File > Quit.

8. Eject the CD from the drive:

Select the CDROM icon on the remote system’s desktop, hold down the
right mouse button, and choose Eject.
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Installing Software on a System Without a Graphical Interface

This section includes:

• “Installing Applications on a System Without a Graphical Interface” on
page 42

• “Installing 6.5.x on a System Without a Graphical Interface” on page 43

Installing Applications on a System Without a Graphical Interface

If you are installing application software (not upgrading the IRIX operating
system), it is not necessary to restart the system and perform the installation
from the miniroot. Instead:

1. Open a shell and enter su  to become superuser.

2. Enter inst .

3. Enter from  followed by the distribution path. For example, if you are
installing from a local CD-ROM drive, enter from /CDROM/dist

4. Proceed to the Product Selection section of “Installing 6.5.x on a System
Without a Graphical Interface” on page 43.
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Installing 6.5. x on a System Without a Graphical Interface

Note: If you are installing onto a system running IRIX 6.5 or later, you can
perform a live (non-miniroot) 6.5.x installation if you first install the
“Installation tools to support overlays” patch. To perform the live installation:

■ Install the “Installation tools to support overlays” patch from the
installtools directory of the Installation Tools and Overlays CD.

■ Follow steps 1 through 3 in “Installing Applications on a System
Without a Graphical Interface” on page 42.

■ If you want to switch to a different release stream, a special command
must be entered when the Inst prompt appear—follow the
instructions in “Switching Release Streams” on page 6.

■ Continue to steps 1 through 3 below, then skip to step 10 below.

If you are installing onto a system running a pre-6.5 version of IRIX, follow all
the steps below. You may also be interested in the “Quick Summary for
Experienced Inst Users” on page 25.

Before You Begin

1. Confirm that you have the appropriate CDs or distributions. At the
minimum, you need:

• The latest 6.5.x Installation Tools and Overlays
(use this instead of the 6.5 Installation Tools CD).

• Any other CDs included in your 6.5.x package.
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• These CDs from the core 6.5 CD package:

– IRIX 6.5 Foundation 1

– IRIX 6.5 Foundation 2

– IRIX 6.5 Applications (use if you did not receive a new
Applications CD in the Overlay package)

– IRIX 6.5 Development Foundation (use if you are a developer)

– IRIX 6.5 Development Libraries (use if you are a developer)

• In addition to the CDs listed above, you probably received other CDs
with your IRIX 6.5 package, depending on your configuration. For
example, there are separate CDs for NFS and SoftWindows. If you
have already installed older versions of any of these products,
upgrade them during this operating system upgrade. If you do not
open the CDs that contain products you have installed, “conflict”
messages during installation will prompt you to open them.

2. Print or check the Start Here pages for information you need before you
begin, such as:

• minimum system requirements for this release

• any major installation caveats

See “How to Access the Start Here Pages” on page 60.
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Note: The Start Here pages include additional useful information, such as
descriptions of each CD.

Preinstallation

3. Insert the 6.5.x Installation Tools and Overlays CD in the CD drive. (It is
important that you load this CD first.)

Note: If you are using a distribution directory instead of a CD, skip this
step—you will load the Installation Tools directory in a future step.

4. Become superuser and shut down the system:

% su

# shutdown

You see the message Do you want to continue with the
shutdown (yes/no) [no]

5. Enter yes .

6. If prompted, choose Restart, then press Esc  to Stop for Maintenance.

7. You are given a list of choices at the system maintenance menu. Enter 2
for Install System Software.

8. Specify the distribution source:

• If the source is a CD drive connected to the workstation, enter the
number for the local CD-ROM selection. (You may have to press
Enter  twice.)
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• If the source is on another system:

– Enter the number for the remote directory selection.

– When prompted, enter the name of the remote system that contains
the distribution.

– Enter the pathname of the distribution source on the remote system.
For example, if the source is a CD, enter /CDROM/dist .

9. Press Enter  to start the miniroot and Inst.

Rows of dots and various messages appear. Wait for the Inst prompt.

If you wish to switch release streams (for example, to install the feature
stream when you previously installed the maintenance stream), a special
command must be entered when the Inst prompt appears. Follow the
instructions in “Switching Release Streams” on page 6.

Note: If a network error message appears, refer to “Troubleshooting
Remote Installations” on page 54.
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CD or Distribution Reading

Before you enter any selection commands, you must follow steps in this
section to open the CDs or distribution directories so that Inst can read the
product descriptions.

You will be prompted to open CDs again during the actual installation, but
Inst needs to read all the product descriptions first in order to prevent several
product conflicts during installation.

If you have not yet determined which CDs you need, refer to step 1.

10. Tell Inst to read the Installation Tools and Overlays by entering the
appropriate command at the Inst prompt, as described below (depending
on the software location):

Software
location:

To open the
installation tools:

Local CD Enter open /CDROM/dist

Remote CD Open the CD distribution directory on the remote
system, for example: open mars:/CDROM/dist

Distribution
Directory

Open the pathname for the Installation Tools and
Overlays CD, for example:
open mars:/irix/tools
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A Readme message appears.

11. If you have not chosen a release stream during a previous upgrade, you
will see
1. Place me on the maintenance stream.
2. Place me on the feature stream.
3. Cancel

Enter 1 or 2.

If you are not sure which stream to choose, refer to “Overview of Release
Streams” on page 2 for clarification. Unlike patches or patchsets, the files
that are replaced in a release stream are not saved during installation.
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Therefore, if you wish to change release streams after your initial choice,
you may need to reinstall the underlying major IRIX release (IRIX 6.5).
For more information, see “Switching Release Streams” on page 6.

12. When you see a message similar to Install software
from:[/CDROM/dist] , replace the current CD or distribution directory
with the next one:

When installing from a CD, make sure that the prompt indicates that the
installation is from the /CDROM/dist directory. For example, if the prompt
changes to reflect the /CDROM/dist/dist6.5 directory, enter /CDROM/dist
at the prompt.

Software
location:

To replace the
CD or distribution:

Local CD Eject the current CD by pressing the manual eject
button on the CD drive.

Remote CD Eject the current CD by selecting the CDROM icon
on the remote desktop, holding down the right
mouse button, and choosing Eject. (Alternatively,
enter eject /CDROM  in a shell on the remote
system.)

Distribution
Directory

Open the next directory, for example:
open mars:/irix/cd2
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13.  Press Enter  to instruct Inst to read the new CD or distribution directory.

14. Continue to replace and open each CD or distribution directory in the
manner described in the previous two steps. (Use the CDs you collected
in step 1.)

Note: Do not enter “done” until all the CDs or distribution directories
have been read. If you enter “done” too early, you can continue to insert
the rest of the CDs, but you will have to use the open command (as
previously described) each time.

15. When all the relevant CDs or distribution directories have been read,
enter done .

Product Selection

16. To install upgrades and related (prerequisite) products:

Inst>  keep *

Inst>  install standard

Inst> install prereqs

Inst> keep incompleteoverlays

• You may see a no matches  message regarding prereqs , standard ,
or incompleteoverlays . This does not indicate an error.

• If you are installing onto a clean disk, these commands select and
install all standard software, plus necessary prerequisite software and
patches.
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17. (Optional) If you want to view or alter the products that are marked for
installation, enter list:
Inst>  list

Each product is marked:

– The status of products appears as follows: N=new, U=upgrade,
S=same, D=downgrade.

– The selection command that is currently applied to a product
appears as follows: i =install, r =remove, k=keep, where “keep”
means that the product is not marked for installation.

– Product types appear in brackets, as follows: [b] =reBoot needed
after installation is complete, d=Default, r =Required, p=Patch,
o=Overlay, c=Client only.

You may change the installation status of any product in the distribution
listed. Tips for making selections:

• To select software that is not already selected, use the install command.
For example: install ViewKit_dev.sw.lib

• If there is software you do not wish to install, use the keep command.
For example: keep ViewKit_dev.sw.lib

Installation

18. Enter go  at the prompt to begin the installation.

If there are no “Conflict” messages, proceed to the next step.
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If your installation selections have generated conflicts, Inst asks you if
you want to address them now.

Enter 1 for “Address these conflicts now.”

To resolve conflicts, enter conflicts choice choice. For example, enter
conflicts 1b 2a to indicate that for conflict 1 you choose choice b
and for conflict 2 you choose choice a.

• If you need to resolve conflicts by opening a CD, the installation
selections you already made may be altered on the CD you open.
Review what is selected on the CD and deselect or reselect as needed.

• If the list of conflicts is long, enter q to stop viewing the list and
resolve the conflicts currently visible on the screen. Once you’ve
resolved the visible conflicts, enter conflicts  again to view the
remaining conflicts. The other option is to write down all of your
choices before you enter them.

• If a conflict gives you the option of deselecting a product with “eoe” or
“Execution Environment” in the product name, do not choose to
deselect the product. The operating system needs “eoe” products in
order to function properly. Exception: You do not have to install “eoe”
products that are man (manual) pages or relnotes (release notes).

• If you deselected subsystems, conflicts may be generated by
remaining patches that go with the deselected subsystems. However,
because such patches go with subsystems you are not installing, you
do not need to install them.
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19. Enter go  again when all conflicts are resolved.

A preinstallation check begins.

20. When you see a message similar to

Please insert the “ <CD title>” CD
Type Ctrl-C to interrupt

insert the specified CD in the CD drive.

In some cases, the message that indicates which CD to insert may include
Error/Interrupt Menu . This does not signify a problem. Insert the
requested CD, and at the Interrupt prompt enter retry .

It may take several minutes for each CD to install. Eventually a new
message will prompt you to insert the next CD or indicate that the
installation is complete.

Postinstallation

21. When Inst indicates that the installation is finished, enter quit .

Postinstallation processes begin. When they are complete, you see:

Ready to restart the system. Restart?

Enter y  to restart the system, which completes the installation process.

Although every product has an associated release note that informs you
of any major bugs and workarounds, Silicon Graphics has collected
information on bugs that could most significantly affect your experience
once you upgrade, and posted them as “Caveats to Read After



54

Upgrading.” These caveats are installed on your system, by default. You
can see them after you restart and log in. To do so, bring up a Web
browser and enter this address:
file:/var/www/htdocs/WhatsNew/precaveats.html

In addition to reviewing this list, you may want to check “Caveat and
Release Note Updates” at http://support.sgi.com/6.5/ for any
late-breaking information.

Troubleshooting Remote Installations

When a network error message appears during a remote installation, review
the following to see if they apply to your situation:

• Check the network connection; make sure that the cables are secure.

• If you see an error similar to Cannot load network (0)
bootp()< system name >:/CDROM/dist , check that tftp access to the
CDROM is enabled on the remote system. Detailed instructions are in the
online Personal System Administration Guide. To find the section in the
book, search for “tftp.” You can access the book from the Toolchest
(choose Help > Online Books), or from http://techpubs.sgi.com.

• (Only applicable when installing installation tools from a remote source.)
If your system does not have its IP address correctly set in nvram, you will
see these messages in the system monitor when your system tries to reach
a remote distribution:
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Unable to execute network(0)bootp()[ distribution path ]

could not connect to server

Cannot load network(0)bootp()[ distribution path ]

could not connect to server

Unable to continue; press <enter> to return to the
menu.

To correct either problem, you need to change the nvram IP address entry
to match the IP address that is being used by UNIX. This procedure is
described in the following steps:

1. When you see the error messages (shown above) in the System
Monitor, press Enter  to clear messages.

2. From the system maintenance menu, click Enter System Monitor (or
press 5)

3. Enter printenv netaddr  to display the IP address currently set in
nvram.

4. If the address displayed is correct, then stop. Your nvram is set
correctly, and there is a different problem preventing you from
reaching the distribution server. If the address displayed is incorrect
(or if you aren’t sure), proceed to the next step.
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5. This step depends on whether you know the correct IP address:

6. Enter exit  or click Done to return to the maintenance menu.

7. Choose Start System (or press 1). Wait until your system starts up, then
log in normally.

8. From the Toolchest, choose Desktop > Open Unix Shell.

If you know your system’s
correct IP address:

If you don’t know your system’s
correct IP address:

■ Proceed to step 15 below. ■ If your system was not
working properly before
starting the installation, or
if you are installing on a
clean disk, you must stop,
find out the correct IP
address from your
network administrator,
and proceed to step 15
below.

■ If your system was
working properly and
was already running IRIX,
proceed to step 6 below.
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9. In the shell window, enter:

/usr/etc/netstat -in

10. Your IP address will be listed as a series of four numbers separated by
periods (such as 10.10.61.2 ) under the Address  column, usually
in the first line of output. (Ignore the lo0  line and the 127.0.0.1
address.)

11. To confirm your address, enter:

grep `hostname` /etc/hosts

In the above command, be sure to use backward apostrophes (`).

You should see your system’s hostname and the same IP address you
saw in the previous step.

12. Write down your IP address.

13. From the Toolchest, choose System > System Shutdown, then:

– If a Shut Down dialog appears, click OK.

– Press the Esc key when you see Okay to power off.

– Press the Esc key immediately again when you see Starting up
the system.

The System Maintenance menu screen should appear now. (If it
doesn’t, you probably did not press the Esc key soon enough; begin
this step again.)
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14. Click Enter System Monitor on the menu screen (or press 5).

15.  Enter setenv netaddr  followed by your IP address.

For example: setenv netaddr 10.10.61.2

16. Enter exit  or click Done to return to the maintenance menu.

17. Return to the installation instructions you were originally following.
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Accessing the Start Here Pages, Troubleshooting Information,
and Release Notes

This section contains directions on accessing more installation-related
information:

• (Required for IRIX Operating System Installations Only) Follow the
instructions in “How to Access the Start Here Pages” on page 60 before
you install IRIX.

• (Optional) See “How to Access Inst Troubleshooting” on page 61 if you
want to print out troubleshooting documentation for Inst, the program
used for installing an operating system.

• (Optional) See “How to Access Release Notes” on page 62 to find out how
to view product release notes. Product release notes typically include
known bugs and workarounds, a description of changes particular to the
product release, and compatibility information.
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How to Access the Start Here Pages

Reviewing the Start Here pages is the first step in upgrading an IRIX operating
system, but is not applicable for single application upgrades or installations.

1. Insert your most recent Installation Tools CD. (For example, insert the
IRIX 6.5.x Installation Tools and Overlays CD instead of the IRIX 6.5
Installation Tools CD.)

2. Open a Web browser and enter this address:

file:/CDROM/WhatsNew/yourSystem.html

Note: Literally type yourSystem.html ; do not type your actual system
name.

3. Click the Start Here link.

The Start Here pages are also at http://support.sgi.com/6.5/installing.html.

When you are finished with the Start Here pages, return to the relevant
installation instructions, depending on what kind of upgrade you are doing:

• “Installing an IRIX 6.5.x Release on IRIX 6.5 or Later” on page 11

• “Installing an IRIX 6.5.x Release on a Pre-6.5 Version of IRIX” on page 24

• “Installing Software on a System Without a Graphical Interface” on
page 42
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The Start Here pages include key information such as minimum
requirements, major (pre/post-installation) caveats for this release, CD
descriptions, and an overview of the new software included in the release.
After you complete the upgrade, you can access the Start Here pages by
double-clicking the Welcome_to_SGI icon on your desktop.

How to Access Inst Troubleshooting

There is information about troubleshooting network errors during remote
installations in “Troubleshooting Remote Installations” on page 54.

You may want to access (or print out) the Troubleshooting section of IRIX
Admin: Software Installation and Licensing. To access it:

1. Log in.

2. Insert the IRIX 6.5 Base Documentation CD into the CD-ROM drive.

3. Open a shell: From the Toolchest, choose Desktop > Unix Shell.

4. Go to the CDROM directory.

The default CD-ROM directory location is /CDROM, so at the shell
prompt, enter cd /CDROM

5. Enter ./CDinsight  to launch the IRIS InSight book viewer.

6. Click the SGI Admin tab and double-click the IRIX Admin: Software
Installation and Licensing book icon.

The Troubleshooting section is the last section of the book.
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Note: You can also find this book at the Technical Publications Library
Web site at http://techpubs.sgi.com.

How to Access Release Notes

To view product-specific release notes, follow steps 1 through 4 above, then
enter ./CDgrelnotes  to launch the release notes viewer.

Installing Software Licenses

For products that require a license to run, you must activate a license for that
product on your system. You should have received a license information sheet
or label from Silicon Graphics. If you do not have this sheet or label, contact
Silicon Graphics or your local support provider.

Silicon Graphics uses FLEXlm to license its products. The sections that follow
describe how FLEXlm Nodelocked and floating or concurrent licenses are
installed using License Manager. (The terms “floating license” and
“concurrent license” are interchangeable.)

Additional licensing information can be found at
http://www.sgi.com/Products/license.html.
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Installing a FLEXlm Nodelocked License

To install FLEXlm Nodelocked licenses you must invoke License Manager and
install the license. If you are installing a license for XFS Volume Plexing or any
other product that must be installed in a directory other than /var/flexlm, then
refer to the release notes for license installation instructions.

To install the license, follow this procedure:

1. Choose System > License Manager from the Toolchest to open License
Manager.

2. Click the Install... button.

3. Select FLEXlm Nodelock.

4. Click the OK button.

5. Copy all requested fields from the license information sheet or label into
the window labelled “License Manager: Install FLEXlm Nodelock
License.”

6. Click the OK button.

7. Repeat steps 2 through 6 until all licenses are installed.

8. Click the Close button on the main License Manager window.

You are finished installing the license(s). Save the license information sheet or
label; you may need it again later to reinstall your license(s).
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Installing a FLEXlm Floating (Concurrent) License

Note : The information in this section should be used only by the system
administrator of the license server system. If you are an end user of client
software with a floating license that is not functioning, contact your system
administrator.

If you are installing a license for a product that must be installed in a directory
other than /var/flexlm, refer to the product’s release notes for license
installation instructions.

Floating licenses require a network license server. The subsystem
license_eoe.sw.flexlm_server must be installed on that system. Verify that it is
installed by opening a UNIX shell and entering
showprods license_eoe.sw | grep flexlm_server | wc -w

If the result is greater than 0 (for example, 7), the subsystem is installed; if the
result is 0, you must install license_eoe.sw.flexlm_server.

With FLEXlm, a floating license must be installed on the license server and the
license file copied to every client system. The license manager daemon, lmgrd,
should then be started on the license server. You do not need to start license
daemons on client systems

To install the license on the license server system using License Manager,
follow this procedure:
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1. Choose System > License Manager from the Toolchest to open License
Manager.

2. Click the Install... button.

3. Click FLEXlm Floating.

4. Click the OK button.

5. If necessary, enter the Server Host Name in the corresponding field. (To
find the name, enter the UNIX shell command uname -n on the server.)

6. Copy all requested fields from the license information sheet into the
“License Manager-Install FLEXlm Floating License” window.

7. Click the OK button.

8. Repeat steps 2 through 7 until all licenses for the server are installed.

9. Click the Close button on the main License Manager window.

Start the license daemon (only on the license server system):

1. Become superuser.

In a UNIX shell, enter su .

2. Enter chkconfig flexlm on

3. Stop the lmgrd daemon.

Enter /etc/init.d/flexlm stop

4. Start the lmgrd daemon.

Enter /etc/init.d/flexlm start
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5. Exit the root account: enter exit

On any system you wish to access this license from, you must copy (or mount)
the license file (/var/flexlm/license_<server_name>.dat) from the server system
into the /var/flexlm/license_<server_name>.dat file (on all client systems).

You are finished installing the license. Save the license information sheet or
label; you may need it again later to reinstall this license.

Troubleshooting FLEXlm Software Licenses

Use the methods described in this section for basic troubleshooting. See
http://www.sgi.com/Products/license.html for more information.

• To analyze the licenses in the license files, enter the UNIX command

/usr/sbin/lmdiag -c /var/flexlm/license.dat

(or /usr/sbin/lmdiag -c /var/flexlm/license_ serverhost.dat )

 If you see an error message that says the HOSTID is incorrect:

– For a Nodelocked license, enter the UNIX command /etc/sysinfo
-s . If the result does not match the HOSTID string for that product in
the license file, this is the problem.
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– For a floating license, on the server system, enter the UNIX command
/etc/sysinfo -s . Compare the results with the second argument
on the SERVER line, which corresponds to the product in question. If
the two numbers are not identical, this is the problem.

Conditions that might cause the /etc/sysinfo -s results and the HOSTID to
be different include:

– The license may be for a system different from the one it is
installed on.

– The HOSTID may have been entered incorrectly.

– The HOSTID on the system may have changed (replacing the
system board or I/O board can change the HOSTID).

• For trouble with a floating FLEXlm license, configure the lmgrd daemon
on the server to send its output to a log file by adding
-c /var/flexlm/license_ server_name.dat -l
/var/adm/flexlm.log

to the /etc/config/lmgrd.options file, where /var/adm/flexlm.log is the log file.
(Note that -l  is the lowercase letter l, not the number one.) In a UNIX
shell, enter

/etc/init.d/flexlm stop; /etc/init.d/flexlm start

Look at the log file for error messages.

If the application program (or lmstat) cannot connect to the license server,
one of several things may be wrong:
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– The license server may be down, or there may be a network
problem. Verify that the client system can communicate with the
server. In a UNIX shell on the server, enter this command:

setenv LM_LICENSE_FILE /var/flexlm/license_ server_name.dat

Then, enter /usr/sbin/lmstat -a  to verify that the vendor daemon
is running.

In a UNIX shell on the client system, enter lmstat -a  to check if the
system can contact the vendor daemon on the server. Then, from the
client system, enter the command telnet hostname portnumber, where
hostname and portnumber match the SERVER line in the license file.

– The Silicon Graphics vendor daemon may not be running. On the
server, verify that it is running by entering the UNIX command ps
-ef | grep sgifd | grep -v grep . If nothing is returned,
then the vendor daemon is not running.

– The application may not be looking at the expected license file. The
default license file for Silicon Graphics products is
/var/flexlm/license.dat. Verify the contents of /var/flexlm/licensefile.db
to see what files are being looked at. To view contents lists of all
expected license files, enter:

more /var/flexlm/licensefile.db
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• If a warning message appears stating that the license expires in an
incorrect number of days, remove or comment out temporary or
evaluation license(s) in the /var/flexlm/license.dat file for this product.

• The License Password may have been entered incorrectly. Check that the
letters l and O were not typed in place of a numeral 1 (one) and 0 (zero).

• Run the date command by entering date . Make sure the date is not earlier
than the Start Date or later than the Expiration Date listed on the license
information sheet.

For more information on troubleshooting, refer to Appendix B of the FLEXlm
End User Manual. This guide is located in the IRIS InSight Library (on the
EndUser Bookshelf), which you can find by choosing Help > Online Books
from the Toolchest.



70


